Vous êtes ici : Accueil > Ressources > Algorithmique > Test algo
Publié : 4 juillet 2017
Format PDF Enregistrer au format PDF

Test algo

AlgoTest Irem 2015

Exercice 1

Langage naturel

X prend la valeur 6
X prend la valeur X+1
X prend la valeur X+1
Afficher X

Quel est l’affichage obtenu ?

Scratch



Quelle valeur dit le lutin ?

Exercice 2

Langage naturel

X prend la valeur 6
X prend la valeur X-1
X prend la valeur X+2
Afficher X

Quel est l’affichage obtenu ?

Scratch


Quelle valeur dit le lutin ?

Exercice 3

Pour i allant de 2 à 4
     Afficher i
Fin pour

Quel est l’affichage obtenu ?

Exercice 4

Langage naturel

X prend la valeur 6
Pour i allant de 1 à 3
  X prend la valeur X+1
Fin Pour
Afficher X

Quel est l’affichage obtenu ?

Scratch


Quelle valeur dit le lutin ?

Exercice 5

X prend la valeur 6
Pour i allant de 1 à 3
  X prend la valeur X+i
Fin Pour
Afficher X

Quel est l’affichage obtenu ?

Exercice 6

Langage naturel

Entrer un entier naturel N compris entre 0 et 20
R prend la valeur "Moyen"
Si N>12 alors R prend la valeur "Bien"
Si N<8 alors R prend la valeur "Insuffisant"
Afficher R
 

Quel est l’affichage obtenu ?

lorsqu’on entre 10 pour N

lorsqu’on entre 5 pour N

lorsqu’on entre 15 pour N

lorsqu’on entre 12 pour N

Scratch

Que dit le lutin ?

lorsqu’on entre 10 pour N

lorsqu’on entre 5 pour N

lorsqu’on entre 15 pour N

lorsqu’on entre 12 pour N

Exercice 7

Langage naturel

Entrer A
Entrer B
A prend la valeur B
B prend la valeur A
Afficher A
Afficher B

Quel est l’affichage obtenu lorsque l’on entre 3 pour A et 7 pour B ?
A vaut et B vaut

Scratch

Que dit le lutin lorsque l’on entre 3 pour A et 7 pour B ?

A vaut et B vaut

Exercice 8

Langage Naturel

Entrer Q
PU  prend la valeur 7,5
Si Q>= 3 alors PU prend la valeur PU-1,5
P prend la valeur PU*Q
Afficher P
 

Quel est l’affichage obtenu ?

lorsqu’on entre 1 pour Q :
lorsqu’on entre 5 pour Q :

Scratch

Que dit le lutin ?

lorsqu’on entre 1 pour Q :
lorsqu’on entre 5 pour Q :

Exercice 9

Langage naturel

Entrer un entier naturel A
Si A>5 alors A prend la valeur A/2
Afficher A

-Parmi les nombres ci-dessous cocher ceux que l’on peut entrer pour A pour que l’affichage obtenu soit 4 (2 pts) :








Scratch

-Parmi les nombres ci-dessous cocher ceux que l’on peut entrer pour A pour que l’affichage obtenu soit 4 (2 pts) :








Exercice 10

Langage naturel

Entrer un entier naturel A
Si A est pair
alors R prend la valeur 0
sinon R prend la valeur 1
Fin si
Afficher R

Quel est l’affichage obtenu lorsqu’on entre 26 pour A ?
Quel est l’affichage obtenu lorsqu’on entre 15 pour A ?
Quel est l’affichage obtenu lorsqu’on entre 2 365 413 pour A ?

Scratch

Que dit le lutin, lorsqu’on entre 26 pour A ?
Que dit le lutin, lorsqu’on entre 15 pour A ?
Que dit le lutin, lorsqu’on entre 2 365 413 pour A ?

Exercice 11

Langage naturel

U prend la valeur 5
N prend la valeur 0
Tant que U>=3
   U prend la valeur U-1
   N prend la valeur N+1
Fin tant que
Afficher N

Quel est l’affiche obtenu ?

Scratch

Que dit le lutin ?

Exercice 12

Langage naturel

Entrer un entier naturel U
D prend la valeur 0
Tant que U>=10
  U prend la valeur U-10
  D prend la valeur D+1
Fin tant que
Afficher U
Afficher D

Quel est l’affiche obtenu lorqu’on entre 23 pour U ? L’affichage obtenu est 5 12. Quelle valeur a-t-on entrée pour U ?

Scratch

Que dit le lutin lorqu’on entre 23 pour U ? Le texte du lutin est 5 puis 12. Quelle valeur a-t-on entrée pour U ?

Exercice 13

Langage naturel

Entrer un entier naturel n
k prend la valeur 0
F prend la valeur 1
Tant que n-k>0
  k prend la valeur k+1
  F prend la valeur F*k
Fin tant que
Afficher F

Quel est l’affichage obtenu lorsqu’on entre 3 pour n ? Quel est l’affichage obtenu lorsqu’on entre 5 pour n ?

Scratch

Que dit le lutin lorsqu’on entre 3 pour n ? Que dit le lutin lorsqu’on entre 5 pour n ?

Exercice 14

Enoncé

Ecrire un algorithme qui affiche la table de
multiplication par 7.

Exercice 15

Enoncé

S prend la valeur 0
Pour k de 1 à 5
S prend la valeur S+k
Fin Pour
Afficher S

Modifier cet algorithme et le réécrire pour qu’il affiche toutes les valeurs successives prises par S.

Réponse

S prend la valeur 0
Pour k de 1 à 5
S prend la valeur S+k
Afficher S
Fin Pour